Vulnerability & Exploit Database

Back to search

IBM AIX: openssl_advisory9 (CVE-2014-0198): Vulnerabilities in OpenSSL affects AIX

Severity CVSS Published Added Modified
4 (AV:N/AC:M/Au:N/C:N/I:N/A:P) May 06, 2014 November 30, 2017 February 02, 2018

Description

The do_ssl3_write function in s3_pkt.c in OpenSSL 1.x through 1.0.1g, when SSL_MODE_RELEASE_BUFFERS is enabled, does not properly manage a buffer pointer during certain recursive calls, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via vectors that trigger an alert condition.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

ibm-aix-openssl_advisory9

Related Vulnerabilities